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What is Requirements Engineering? 

The proper definition for the term Requirements 
Engineering is: 

“...the process of formulating, documenting and 
maintaining software requirements”



A Working Definition 

I am using a broader definition to conceptualise this within 
the idea of scholarly project ideation and delivery: 

“...the process of imagining, defining, formulating, 
documenting and turning software requirements into a 

user-centred project.”



In Simplest Terms: 

How do you make an Idea come real in a 
multidisciplinary, interdisciplinary and 

multi-stakeholder collaboration? 

Even as a solitary scholar?



Even Simpler: 

Some things (a way of thinking) that you can 
do before you begin, during and afterwards 

that may not be immediately obvious – or 
possibly implicit; 

A new way of approaching digital research 
projects from a design thinking perspective 

combined with user-centred design principles.



There’s an ISO Standard for That

http://www.iso.org/iso/catalogue_detail.htm?csnumber=52075


ISO Defined Principles
1. The design is based upon an explicit understanding of 

users, tasks and environments. 
2. Users are involved throughout design and development. 
3. The design is driven and refined by user-centered 

evaluation. 
4. The process is iterative. 
5. The design addresses the whole user experience. 
6. The design team includes multidisciplinary skills and 

perspectives.



A Simplified Look at UD-Driven Process 
‣ Linear but Iterative



Why Consider the Users?
‣ People often consider the sustainability of their research and digital 

outcomes ... 
‣ Funders ask for a sustainability statement …  
‣ Why? 
‣ You invest a lot of time and effort: 
‣ → If people use your work it will be sustained; 
‣ → Finding sustainable funding on your own is difficult; 
‣ → Creating an enthused and invested user base easy. 

‣ Release Early, Release Often …  
Involve Real Users!



Who Has Been Involved with User 
Driven Design Before?



Why? // Why Not??



As a Sidenote
‣ There are a variety of useful tools to support the 

processes (a couple of which we will mention in due 
course).  

‣ There is an ethos of transparency inherent in this 
process. 

‣ A design process I was involved with can be seen at: 

‣ https://web.archive.org/web/20100722165014/http://
tada.mcmaster.ca/Main/OldMashTexts 

‣ A freely accessible wiki used to document the process 
during the process - hint!

https://web.archive.org/web/20100722165014/http://tada.mcmaster.ca/Main/OldMashTexts


Ideation

‣The thought cycle:  

‣generating, developing and 
communicating new ideas 

‣ innovation → development → actualisation



So … are we talking about?
● the Rational Unified Process 
● Extreme Programming 
● Scrum 
● Agile 
● …..





Activity 1 : Understand the Idea
‣ Choose from a few potential projects;  
• How big is project? 
• What may it involve, etc... 
• Who do you think you might be involving to bring this 

together? developer, researcher, etc...not as users, but 
as creators? 

• Have you seen anything similar? 
• Do you have the background to carry this out? 
• What Challenges to this project can you imagine?



Breakout: 15 Minutes 

Understand your Big Idea 

Report Back to the Group



Share the Ideas



Describing your Project
‣ What’s an Elevator Pitch? 
‣ What is a Research Question? 
‣ How are these different? 

‣ Can You Tell a Good Story? 
‣ Funders like to be inspired in all spaces 
‣ Can you inspire them with your idea?



So What??



Answering ...
● Clarity and precision no sweeping generalizations or 

irresponsible statements; 
● Avoiding the use of buzzword-based terms; 
● Identification of an overarching question and key factors or 

variables, 
● Definition of the project scope; 
● Identification of applicability and delivery of results into general 

use, 
● Project/product importance, benefits, and justification -  it’s not 

trivial; 
● No unnecessary jargon.



A Useful Tool - Ideation - Exobrain

https://www.exobrain.co/


A Useful Tool - Ideation - CoDigital

http://app.codigital.com/p/pr-f7e9ab653ff18fabb4e8e3d508fbe61a#


Other Tools
‣ MindMeister 
‣ Omnigraffle 
‣ Dia 
‣ LucidChart 
‣ FreeMind (OS) 
‣ MindManager

https://www.mindmeister.com
https://www.omnigroup.com/omnigraffle
https://sourceforge.net/projects/dia-installer/
https://www.lucidchart.com
http://freemind.sourceforge.net/wiki/index.php/Main_Page
http://www.mindjet.com




Activity 2 Identify Objectives
‣ Consider the objective(s) of the project.  
‣ Generate a short project statement in the form: 
‣   
‣ This digital project is for (target ), who has (need). 

(Project name) is a (category) that (key benefit), unlike 
(existing services/projects), the project (unique 
differentiator). 

‣ 15 – 20 minutes



User-Centred Design (UCD ;-)
‣ Sometimes linked with User Experience (UX) 

‣ “User-centered Design is an approach that 
grounds the process in information about the 
people that will use the product.” 

‣ Usability Professionals Association



An Actual International Standard
‣ ISO standard Human-centred design for interactive 

systems (ISO 9241-210, 2010) 
● Based upon an understanding of users, tasks and 

environments; 
● Users involved throughout design & development; 
● Design driven and refined by user-centered evaluation; 
● Process is Iterative; 
● Design team includes multidisciplinary skills and 

perspectives.



An Example - Website User Objectives
1. Who are the users of the site? 
2. What are the users’ tasks and goals? 
3. What are the users’ experience levels with the site, or sites like it? 
4. What functions do the users need from the site? 
5. What information might the users need, and in what form do they 

need it? 
6. How do users think the site should work? 
7. What are the extreme environments? 
8. Does the interface utilize different inputs modes such as 

touching, spoken, gestures, orientation, mobile or desktop?



Design Thinking
‣ Shared objective: 
‣ What IDEO calls design thinking, brings together what is 

desirable from a human point of view with what is 
technologically feasible and economically viable. 

‣ OPENIDEO Resources

https://challenges.openideo.com/content/resources


d.school @ Stanford
‣ Learn by doing:  
‣ Define what the problem is.  
‣ Start in the field.  
‣ Develop empathy. 
‣ Iterate to develop a range of  

solutions. 
‣ Create rough prototypes to test.  
‣ Experience measured by iteration. 
‣ Each cycle brings stronger insights and more unexpected 

solutions.



Information Architecture
‣ Information architecture describes the structure of a 

system: 
● the way information is grouped; 
● navigation methods; 
● terminology used within the system.





Collaborative Writing Tools
‣ PiratePad 
‣ GitHub



Activity 3 - Identify Potential Users
‣ Identify of all potential users, groups, (stakeholders) that 

may benefit from or make use of the digital output from 
the project being considered.  

‣ Be specific, be broad, think outside the box, be 
unconstrained. Who might stumble upon it on the web? 
Who might attempt to misuse it?  

‣ 15 -20 minutes



We are Going to Mine These Lists after …



Lunch
phew ;-)





Building Personas
‣ Personas act as stand-ins for real users 
‣ Archetypal users that represent larger groups; 
‣ Represent: 
● motivations; 
● expectations; 
● goals.



Personas Contain
‣ Bring users to life:  
● giving them names; 
● personalities; 
● a photo 
‣ This can become as intensive as you want to take it 

depending on needs/resources/time.



Not without Detractors
‣ A waste of time because personas are fake; 
‣ Personas are not real user profiles; 
‣ Personas don’t talk back - can’t answer questions; 
‣ Personas silly and unrealistic as they start predicated on 

an imagined need.



Well ...
‣ Fake? - Based on real data 
‣ Not Credible? - Avoid chosen individuals and single 

viewpoints 
‣ Don’t Talk Back? - Force you to engage with real people 

to build 
‣ Unrealistic? - A matter of when you start thinking about 

users



Ultimately … the Benefits
‣ Personas help prevent you designing products for 

yourself and your own needs 

‣ Personas facilitate and ongoing dialog between creator 
and user



Sample
‣ http://tada.mcmaster.ca/Main/DEEPStorieS



What to Include
‣ Basic demographics such as age, job, family, 

hobbies and interests 
‣ What a typical day looks like 
‣ Common questions or tasks in relation to 

the digital project you are proposing 
‣ Major frustrations when trying to achieve 

goals related to the what you propose to 
offer.  
For example, inability to find material 
online and having to travel to archives and 
listen to source material on a reel-to-reel 
tape machine that is often broken. What 
frustrates the person most about 
researching and working with the material 
(online and offline)?

• What the person likes best about the 
proposed and at this stage still imaginary 
product. For example, being able to 
compare, collect and come back to a 
saved set of specific digital recordings. 

• Who does the person interact with most 
when completing tasks? For example, does 
the person rely on the online research 
portal entirely or do they interact through 
an online forum sharing knowledge and 
working collaboratively. 

• Skill levels relating to tasks as well as 
technology 

• Goals, attitudes, beliefs (conscious and 
subconscious)



Where Can You Get User Data?
‣ Surveys - inexpensive and broad; 
‣ Focus Groups - more expensive but deep; 
‣ Contextual Interviews - €€’s but iterative; 
‣ Metrics and Usage Data - Need past product/project



Useful Persona Tips
● Keep personas to one page - simple + memorable; 
● Separate by goals, not by behaviors; 
● Add personal details but avoid being phony; 
● focus on covering a wide swath of audience; 
● Identify the primary and secondary personas to help direct design 

priorities; 
● 3-4 goals per persona; 
● if two personas seem close in behaviours and goals, see if you can 

merge them into one persona; 
● represent behaviour patterns, not job descriptions.





Activity 4 - Building Personas
‣ Create persona descriptions for 3 of the potential users 

you have listed; 

‣ These should be colourful, potentially narrative and help 
you to imagine real world use by imagining a tangible - 
knowable - individual representing a use group. 

‣ 15 Minutes



Sharing the Personnas
Let’s meet your users



Developing User Cases
‣ Many Ways to Accomplish: 
‣ Usability testing 
‣ Interviewing users 
‣ Discussions with stakeholders 
‣ Conducting surveys 
‣ → Building Personas and Writing User Stories



Collaborative Tools

http://www.mediawiki.org/


Alternatives
‣ PBWorks 
‣ Docuwiki 
‣ TikiWiki

http://pbworks.com/
http://c2.com/cgi/wiki?DokuWiki
http://c2.com/cgi/wiki?TikiWiki


Writing Scenarios
‣ What is a Use Case? 
‣ “a natural language description of a user’s 

interaction with a system and as such considers 
the users perspective or point of view.” 

‣ “The beauty of use case is that it aims at 
describing a system from external usage 
viewpoint”



Don Norman
‣ Appropriate to Introduce Don Norman at this point. 
‣ “The Design of Everyday Things” 
‣ Good versus Bad Design 
‣ Simplifying the structure of tasks; 
‣ Making things visible; 
‣ Designing for error.



How to Write a Use Case
1. Choose a very specific objective task; 
2. Express as a Verb + Noun; 
3. You can chain tasks later;  
4. Break down into as granular steps as possible; 
5. Define what the user experiences 
6. Tell a story in steps.



Example





Activity 5: Building Use Cases
‣ Take your personas. 
‣ Write a series of three use cases describing in as much 

detail: 
1. How each user will actually work with the project/tool/

website/etc.  
2. What will they see, what will they do 
3. What will they get?  
4. Are they happy, are they frustrated? 
5. Do they go down blind alleys?  
‣ Again, no constraints.



It may help to think visually



Wireframing
‣ Principles 
‣ Tools 
‣ Kind of Like Storyboarding 

‣ “Within the process of building a website, wireframing is 
where thinking becomes tangible.” 

‣ Wodtke, Christina; Govella, Austin (2009). Information Architecture: Blueprints for the Web, Second Edition. 
New Riders. 168.



Sample



3 Key Elements of the Wireframe
1. Information Design - What Data 
2. Navigation Design - How Users will View Data 
3. Interface Design - How Users Interact with System



Taking Primitives/Building Blocks



Suggested Software Tools
‣ Paper (OK - not digital but still a contender) 
‣ Balsamiq (Chrome App) 
‣ Gliffy 
‣ Mockflow 
‣ Framebox 
‣ UXPin 
‣ JustinMind 
‣ C.ROWE Wireframing Kit

https://mockups-gdrive-bmpr.appspot.com
http://www.gliffy.com/
http://www.mockflow.com/
http://framebox.org/
http://www.uxpin.com
http://www.justinmind.com
http://theycallmecrowe.com/advice/crowe-wireframekit.html




Imagining Inputs - Process - Outputs
‣ What Are Your Raw Materials? 
‣ How Do You Process These? 
‣ What are You Generating at the End?



Input
‣ What already exists in the area? 
‣ In what formats do your materials exist? 
‣ Are they digital already? 
‣ If so are there tools that can work with them? 
‣ Crucially, what do you have to work with? Much like 

users, good to write about just to get thoughts in line.



Process
‣ The importance of standards - input/output 
‣ How will you transform the materials? 
‣ What does this add to them? 
‣ How will you capture the transformation? 
‣ Is it reversible? 
‣ How can you demonstrate/expose it to your audience?



Output
‣ How will you share your data? 
‣ Can you share your data 
‣ What IP issues are involved? 
‣ How can you license it? 
‣ How might people reuse it? 
‣ What are the implications of these?



Activity 6 - Drawing Pretty Pictures
1. Visualise the stories that you have written above.  
2. Imagine the digital interaction space that will support 

the use cases.  
3. Roughly develop wireframes that illustrate what the 

user will see on screen…boxy, no artists, unless you 
really are.  

4. Output a set of storyboards illustrating the use cases 
you have written.



Step 7 - Build a Descriptive Document
‣ Combine pieces into a cohesive document that will: 
‣ Help guide us as we develop 

a project plan; 
‣ Allow us to share our idea, 

concept with a wide 
audience of potential  
partners all speaking 
different languages and  
living in different worlds. 

● Select one persona/user; 
● One use case; 
● One story board/wireframe. 

http://tada.mcmaster.ca/Main/DEEPStoryOne


Best Practise Technology Decisions
‣ There are Tools, but … 
‣ Documentation 
‣ Transparency 
‣ Communication 

‣ → Digital Project Management



A Good Wiki
‣ Reclaim Hosting 
‣ MediaWiki 
‣ TikiWiki 
‣ PBWorks



Shared Document Management
‣ Google Docs 
‣ App Suite 
‣ Zoho



Collaborative Writing Tools
‣ PiratePad 
‣ GitHub



This Simplified Look at a UD-Driven Process 
‣ Linear but Iterative 

‣ Fluid and Reflective



Thank You
Shawn Day 
@iridium


